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mux2to1.qpf (E/quar1glite/de10/mux2to1/mux2to1.qp)
led_1sec.qpf (E/quar18lite/de10/led_1sec/led_1secqpf)
count0to.qpf (E/quart 8lite/count0to8/countotod.qpf)
mux4to1_syn.qpf (E/quarislite/mux4to_syn/muxdtol_syn.qpf)

a New Project Wizard ‘5; Open Project

Euy Software Support \nats New Notifications

x [quartus prime Tc1 console
feb

s | (O] 8] 4] A 88 cinc.. | |88 Find e

H Type ID Message

X I'n https://hayunavi.wixsite.com/avihayun DE10-Lite *a17? |on



https://hayunavi.wixsite.com/avihayun

N1dIND DY ATIAYA NIV NITIA
D100 N1y NMI90 NI¥PNY? 'R .1
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DY
File => New Project Wizard - project Nnn'no e

Ok New Project Wizard *

Introduction

The New Project Wizard helps you create a new project and preliminary project settings, including the following:

Project name and directory

Name of the top-level design entity
Project files and libraries

Target device family and device
EDA tool settings

* 4+ e

‘You can change the settings for an existing project and specify additional project-wide settings with the Settings command (Assignments
menu). You can use the various pages of the Settings dialog box to add functionality to the project.

1 Don't show me this introduction again

< Back Finish Cancel Help

(¥ New Project Wizard X

Directory, Name, Top-Level Entity

What is the working directory for this project?

|E'\vhdt‘\mux2to'l |

‘What is the name of this project?

|mux2to‘| |

What is the name of the fop-level design entity for this project? This name is case sensitive and must exactly match the entity name in the

design file

|mux2to‘| |

Use Existing Project Settings..

< Back FEinish Cancel Help
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%Y New Project Wizard x

Project Type

Select the type of project to create.

® Empty project

Create new project by specifying project files and libraries, target device family and device, and EDA tool settings

O Project template

Create a project from an existing design template. You can choose from design templates installed with the Quartus Prime software, or
download design templates from the Design Store.

|| Einish || Cancel || Help

Ok Mew Project Wizard x
Add Files

Select the design files you want to include in the project. Click Add All to add all design files in the project directory te the project.

Note: you can always add design files to the project later.

File name: | ||:|

|
File Name Type Library Design Entry/Synthesis Tool HDL Version FamiEs
Up
Down
Properties
Specify the path names of any non-default libraries.
| Einish | | Cancel | | Help |
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(h Mew Project Wizard
Family, Device & Board Settings

Device Board

Select the family and device you want to target for compilation

DE10-Lite 0'0Y27 D'RkNNN 2D N2

You can install additional device support with the Install Devices command on the Tools menu.

*

To determine the version of the Quartus Prime software in which your target device is supported, refer to the Device Support List webpage.

Device family

EamilyEAx 10 [DNDF!DC!SMSC}]

Device: |All

Target device
Auto device selected by the Fitter
® Specific device selected in ‘Available devices' list

Other. nfa

Ayailable devices:

Show in *Available devices' list

Package: Any

Fin count: Any

Core speed grade: | Any

Mame filter:

Show advanced devices

Name Core Voltage LEs Total IfOs GPI0s Memory Bits Embedded multiplier ¢ ~
l‘IOMSODAF4S4C?G I 1.2v 48760 360 360 1677312 288 v
< >
< Back Cancel Help
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File =>New WwTNn yalp NNo e
VHDL2aIoYM e

OrF <D0 D C | muxeto S D FRES @A

roject Nawgamr| 4% Hierarchy i |Q 2ax
G New
Entity:Instance
% MAX 10: 10MOBDAF484C8G New Quartus Prime Project
#* muxztol B ~ Design Files

AHDL File
Block Diagram/Schematic File
EDIF File
Qsys System File
State Machine File
SystemVerilog HDL File
Tel Script File
erilog Ol Eile
~ Memory Files

Hexadecimal (intel-Format) File

Memory Initialization File

¥ Verification/Debugging Files
In-System Sources and Probes File

Logic Analyzer Interface File

4 >

x |Quartus prime Tcl Console
& |t

:EDITOR - NONM NNAN N'DINN DX AMND @

library ieee;
use ieee.std logic 1164.all;

entity mux2tol is
port( DO,Dl: in std logic;
SEL: in std logic;
F: out std logic);
end mux2tol;

architecture arc mux of mux2tol is

begin
F<=D0 when SEL ='0' else
D1 ;

end arc mux;

File =>Save As Yalpn DR INY

X oW Ny
[-§ mux2tol nupna wean (LR mux2tol < vhdl ¢ (B} 'mipnpoT » 4
® -:= nwinapm v 7o
Elle} 1Y TN ow  “n-nanwpian Zf
0wap Nepm 01/11/2019 00:05 db nmin
apon
oInon
oo
AT N B
niinn &=
(C:) ipn poT i
05 (D)
(E) 'DIpN PO'T oy

—

v | tyaip ow

WHDL Files (*.vhd *.whdl) | 102 INW

| Add file to current []

!
| e | | e project NIEmAnon A

entity Level Top - NnI2aN NN YW DWUN NINW UR'N9N DY) Yalzn YW DY

X I'n https://hayunavi.wixsite.com/avihayun DE10-Lite *a17? |on


https://hayunavi.wixsite.com/avihayun

Yaljpn NX 79np

(h Quartus Prime Lite Edition - E/vhdl/muwtol/muwdtol - muwdtol
File Edit WView Project Assignments Processing Tools Window Help

DP’TG r ")C‘ ‘muxEkﬂ '|=‘.é¢'f," @8’ V.Q @i‘i&ﬂ L4

Project Navigator‘ 4% Hierarchy '|Q pe x| & mux2tol.vhd ]
l Tibrary ieee;
Entity:Instance . use ieee.std_logic_1164.a11;
3
4% MAX 10: 10MOBDAF484C8G 4 Eentity mux2tol is
> N 5 = port( DO,D1l: in std_logic;
mux2tal 6 SEL: in std_logic;
7 F: out std_logic);
8 end mux2tol;
9
10 Harchitecture arc_mux of mux2tol is
11  mEhbegin
12 F<=D0 when SEL ='0" else
13 ol ;
14 end arc_mux;
15

:N'X¥7IM'07 "N2I WTN yal NNo

D Quartus Prime Lite Edition - E/vhdl/mux2tol/muxto? - muxtol

File Edit View Project Assignments Proc Tools Window Help
D d|# nD» mux2tol LSS DrFESSLAVER
ijedNavigator‘ A Hierarchy "Q pa x| & = 9 Compi
o * —
Entity Instance Table of Conte
% MAX 10: 10MOBDAF484C8G B3 Flow State Machine File ~
B ruton 1B EH Flow SystemVerilog HOL File s
EH Flow Tel Script File Fsion 1€
EH Flow Verilog HDL File o
EH Flow VHDL File ame m
v
E Flow Memory Files M
Hexadecimal (Intel-Format) File
> M Analyd ! d 1c
Memory Initialization File
> 19 Fiter Fit
° ™ Vverification/Debugging Files
Flovg In-System Sources and Probes File 3 2
O Flow Logic Analyzer Interface File o
> I8 assen ig palizer File 4,
> I Timin, University Program VWF 0
v Other Files o,
AHDL Include File ier 9-bit elements 0,
Block Symbol File o,
Chain Description File ®
. " v b
< bR 1005 Desian Constraints File | 0,
| x |Quartus prime Tcl console ‘ Cancel ‘ | Help ‘

an2 ,Name 1ITNA 1202 Nt ynY

WValue at ap= s
Mame
Ops 0 ps
4
. Delete Del
Insert Node or Bus...
Grouping »

Edit n'1w7 NN 1IN127 IX

(@ Simulation Waveform Editor - E:/quarl8lite/muxctol/muxte] - muwtol - [Wav

File | Edit View Simulation Help

h X Delet el AT L
Mast Insert b Insert Mode or Bus._.
Value 4
. 0.0 ns 320.0ns
Grouping » i i
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a MNode Finder

(Ol Insert Node or Bus *
Mame: ‘Use Node Findertninsert...| ‘ OK ‘
Type: ‘INPUT

| Comt |

Value type: ‘S—L'EUE{

Radix: ‘ Binary
Bus width: “I |
Start index: ‘0 |

Display gray code count as binary count

x

Mamed: [* |Filter ‘Pins:all - | OK |

Lookin: |* ‘D | Cancel ‘

Nodes Found: Selected Nodes:

Name Type MName Type
O Node Finder >
Mamed: |* | Filter: ‘Pins: all " | OK |
Look in: |* ‘EI ‘ List | ‘ Cancel ‘
Nodes Found: Selected Nodes:
MName Type Mame Type
in
m DO Input
& D1 Input .
wor Output [
in
= SEL Input .
<

=
[«

X |I'N
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ik Node Finder =

Named:

| Filter: |Pins:a

1

Lookin: |* | |z| | List | Cancel
Nodes Found: Selected Modes:
Mame Type Type
iﬁ_ Do Input : Input
iﬁ_ D1 Input Input
W F Output Output
B SEL Input Input

O Insert Node or Bus X
Name: **Multiple lterns** |_ OK

g
Type: |*”Multi ple ltems** A | Cancel

Value type: | 9-Level

Radix: | Binary
Bus width: |‘I
Start index: |0

Display gray code count as binary count

AI'KN 97 SEL, D1 -7 50nsec , DO-7 20nsec [AT2 |IVW XNAIT? , D'72 010N

& Simulation Waveform Editor - Ei/vhdl/mudtalt/mwdtolt - mwtolt - [Waveform.vwf]*

File Edit

View Help
Rle oo 200 E 8 E(E) n w8 e 2 =8

Value at 0 ps B()(I) ns 15()‘() ns 24()I() ns 32()‘() ns 4()()‘() ns 4BOI() ns 55()‘()
Name
Ops ps
L
» DO BO
L m BO
£ F BX
- SEL BO
G Clock x
Base waveform on time period
o T
o Editor - mtot - =&
Flle Edt view Simulaton help -

k(@58 &N 2 XX WX

se. Bo [ 1

N | [ e =1 Jone
| vk
Ops
- Do BO
£
o

£ Bx L S RS
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:} Simulation Waveform Editor - E:/vhdl/mucto 1t/ muwetot - muto 1t - [Waveform
File Edit WView Simulation Help

L »ﬁ&hi)@)@%)@)@)@)@lﬁkﬁh 2 B

Master Time Bar. |D ps | 1 * | Pointer: [52.69
Value at 0 ps EO{I} ns 1 E'DiO ns é
MName - P

[nion? mm TRON 7Y yN'71 ,2'70 7w NIfMwnn 1T 0y nx1l OX

NXIN MNX

G Simulation Waveform Editor - E/vhdl/mux2te1t2/muwctol - muwtol - [mudtol_20191119203134.sim vwf (Read-Only)] -
File Edit View Simulation Help
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Table 3-3 Pin Assignment of Push-buttons

Signal Name FPGA Pin No. | Description I/0 Standard
KEY0D PIN_B8 Push-button[0] 3.3 V SCHMITT TRIGGER"
KEY1 PIN_AT Push-button[1] 3.3 V SCHMITT TRIGGER"

ST

Figure 3-15 Connections between the slide switches and MAX 10 FPGA

Table 3-4 Pin Assignment of Slide Switches

Signal Name FPGA Pin No Description WO Standard
SWo PIN_C10 Slide Switch{0] 3.3-VLVTTL
SwWi1 PIN_C11 Slide Switch(1] 33-VLVTTL
Sw2 PIN_D12 Slide Switch{2] 3.3-VLVITL
SW3 PIN_C12 Slide Switch{3] 3.3-VLVTTL
SW4a PIN_A12 Slide Switch{d] 3.3-VLVTTL
SW5 PIN_B12 Slide Switch{5] 3.3-VLVTTL
SW6 PIN_A13 Slide Switch{6] 3.3-VLVTTL
SW7 PIN_A14 Slide Switch{7] 33-VLVTTL
swa PIN_B14 Slide Switch{8] 33-VLVTTL
swa PIN_F15 Slide Switch{9] 33-VLVTITL

Table 3-5 Pin Assignment of LEDs

Signal Name FPGA Pin No. | Description 'O Standard
LEDRD PiN_AS LED [0] 33V VTTL
LEDR1 PiN_AS LED [1] 33V IVTTL
LEDR2 PIN_A1D LED [2] 33V LVTTL
LEDR3 PiN_B10 LED [3] 3.3V VTTL
LEDR4 PiN_D13 LED [4] 3.3V LVTTL
LEDRS PIN_C13 LED [5] 3.3V IVTTL
LEDRE PiN_E14 LED [B] 3.3V LVTTL
LEDRT PiN_D14 LED [T] 3.3V LVTTL
LEDRE PiM_A11 LED [8] 33V VTTL
LEDRS PiN_B11 LED [9] 33V VTTL
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Processing Tools

File Edit View Project Assignments
D ™~ r ') mux2iol
Project Mavigator | &% Hierarchy v Qg =

11

window Help

D9 NY'AZ7 0NN e

mux2tol.vhd @ O‘

FPEFES ELOE®

Comg

Entity:Instance

4% MAX 10: 10MOBDAF484CEG

% mux2tel "B

T b wn =
2

Tibrary ieee;
use ieee.std_logic_1164.alT;

Hentity mux2tol is
= port({ DO,D1l: in std_logic;

SEL: in std_Tlogic;
o LTI RE R

LEDR[9] Nana xximi SW[0] j7oon S-7 , KEY[0],KEY[1] n'a¥n'? DO,D1 : Mi01d7 N1 e

(n720n '97 NIMIKD DX DIYAY? 7'90n) |'ON DY Location NTiNy2 DIw)

.Jnionn '97 1/0 -2 n'nNNN NX NNYY

N |I'n

* | Named:| * w |les | Edit] |
=
n Mode Mame Direction 1/ Bank VREF Group Fitter Location 1/O Standard
& Do Input PIN_EB 2.5V (default)
- D1 Input PIN_¥3 2.5V (default)
_ou-t F Cutput PIN_F7 2.5V (default)
- SEL Input PIN_C4 2.5V (default)
<<new node>>
Named| * &) Edit) X
Mode Mame Direction Location 1/O Bank WREF Group Fitter Location I/O Standard Reserved Current Strength
& oo Input PIN_BB 7 B7_NO PIN Y2 33V schmitt Tngger 8mA [default)
i"r D1 Input PIN_A7 7 B7_NO PIN_Ug 3.3 V Schmitt Trigger 8mA (default)
- F Output PIN_B11 7 B7_NO PIN_U7 3.3-V LVTTL 8mA [default)
& SEL Input PIN_C10 7 B7_NO PIN_W6 3.3-V LVTTL 8mA [default)

n'xY7'oNn17 yx11 e
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D'PTN NNXPN? N0 1T

TCL nowa - Script yalza wnnwn? X'N 2970 N'NAL DT NXYPAY NI NNn Noon 0T

#

#

Quartus 7w

:Nan wza DE2 0'010% 0'kNnn yalgn DTN

http://www.amos.eguru-il.com/FILES/DE10 LITE PINS.tcl

OP'NON 7w - Folder 2 TCL yalzn DX |ONK 7Y NI77 D'RNNY Yalpn DX TN

0P'N9N 7w 0'PTNY? # NYn7 IN'on NX 702

I/0 standards
set_instance assignment -—name I0 STAWDARD "3, 3
Zet_instance asgsignment -name IO STANDARD 3.3
444 Pin Assignmenkt #44

set_location assignment PIN BE -to DO ;& EEY[O]
set location assignment PIN AT -to|Dl| :# KEY[1]

I/0 standards

set_instance assignment —name IO STANDARD "3.

it Pi1n Assrignment 444

JTTL" —-to] S5EL

set location assignment PIN C10 —tD FrE SR[0O]

‘0 standards

set_instance assignment —name IO STANDARD "3

444 P1n Assignment 444

set_location assignment PIN E11 —tD r# LED

-V LVITL" —1:|:|

Yalpn 7y DUN DR MY e
Run yanI yaljn NX no , Tools => TCL Scripts NNN Yalgn IR YN e

ax |I'n https://hayunavi.wixsite.com/avihayun

DE10-Lite "a1'? PN


https://hayunavi.wixsite.com/avihayun
http://www.amos.eguru-il.com/FILES/DE10_LITE_PINS.tcl

13

NNy
USB-Blaster nX mpan N7 T 'pNn7 X wr, USB1an) e

N1 N1l e

File Edit Wiew Project Assignments Processing Tools Window Help

D-" I mux2tol A é":""o PF‘F&‘D @ 9
Project Mavigator | 4% Hierarchy rlafge x| $ mux2tol.vhd x|

D Co
-
Entity-Instance Table of Contents ") Flow Summary
e e ie B2 Flow Summary o

(Nn'wna y'am sof Nni'o Dy naMxn yal) Start 7y yn'7a1 USB — Blaster n2aMx7 1Ny e

» Programmer - Ei/vhdl/mux2tol/muxtol - mux2te] - [mux2tol.cdf] — [m] -

File Edit View Processing Tools Window Help

Search altera.com e

[[] Enable real-time ISP to allow background programming when available

Wb ot File Device Checksum Usercode Program/  Verify  Blank- Examin
[ ] Configure Check

b Stop utput_files/mux2tol.sof 10MS0DAF434 0026FC5A 0026FC5A

8 Auto Detect
Delete
B pdd File

< >
P Change File...

A save File

* Add Device

% up

" pown

N2M¥N NN 0'VDN 7Y PITA) e

d

2B i@
e |||ll‘
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