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File => Close Project D"j7 Uj?'IND NA0  ©

File => New Project Wizard ¥Tn O'N® NN'NS e

& New Project Wizard

Introduction

The Mew Project Wizard helps you create a new project and preliminary project settings, induding the following:

Project name and directory

NMame of the top-evel design entity
Project files and libraries

Target device family and device
EDA tool settings

You can change the settings for an existing project and spedify additional project-wide settings with the Settings command (Assignments menu). You can use
the various pages of the Settings dialog box to add functionality to the project.

teeee

[] Don't shaw me this introduction again

< Back

Finish Cancel Help

x

NN NN DYIVP'ND DY , NS0 N e

&4 New Project Wizard

Directory, Name, Top-Level Entity [page 1 of 5]

What is the working directory for this project?

|D:fuuam_|s 13_ex ‘

What is the name of this project?

|mux2t01| ‘

What is the name of the top-evel design entity for this project? This name is case sensitive and must exactly match the entity name in the design file.

|mux2b:|l ‘

Use Existing Project Settings...

< Back Finish Cancel Help

X
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€4 New Project Wizard

Add Files [page 2 of 5]

X

Select the design files you want to indude in the project. Click Add Al to add al design files in the project drectory to the project.

Note: you can always add design files to the project later.

File name:

FleNome Type Lirary Design Entry/Synthess Tool

HOL Verson

Add Al

Remove

Dowm

Propertes

Specify the path names of any non-default ibraries. User Libraries...

< Back

e

DEO- 0'0ND7 O'RNNN QDY N e

& New Project Wizard

Family & Device Settings [page 3 of 5]

Select the family and device you want to target for compilation.

You can install additional device support with the Install Devices command on the Tools menu.

X

Device family
I Family: Cyclone I I A
Devices: All -

Target device
() Auto device selected by the Fitter
© Sspecific device selected in 'Available devices' list

Other: nfa

Available devices:

Show in ‘Available devices' list

Package: Any -
Fin count: Any ~
Speed grade: Any hd
Name filter:

B show advanced devices

=]

HardCopy compatible only

Name Core Voltage LEs User I/0s Memory Bits Embedded multiplier 9-bi
EP3C16F25617 1.2v 15408 169 516096 112
[ EF3C16F484C6 1.2v 15408 347 516096 112

L
Companion device &
HardCopy: -
Limit DSF & RAM to HardCopy device resources
< Back MNext > l[ Finish ] Cancel Help

[I'N AN W



VHDL Tip niy¥nxa 1-7 2 MUX 77100 ,8an 7ayna X D17 aon

A 4

PIN_H2

MUX
221

4

S
(%2
m
—

|
|
|
|
P PIN_G3
|
|
|

|
!
|||—o;

.N1222 7'von XXM LED -1 71 7090, D'UIVNY Ny 7ayn Dy 0D¥N70 yT'nn Niotd

File =>New wTn yaiz nno

EDITOR -1 J0N2 TIzn DX 2IMD

VHDL a10 "'n2

@ MNew

Mew Quartus II Project

~ Design Files
AHDL File
Block Diagram /Schematic File
EDIF File
Qsys System File
State Machine File
SystemVerilog HDL File
Td Script File

Verilog HDL File
VHDL File
v MEFETTTTE

Hexadecimal (Intel-Format) File
Memory Initialization File

~ Verification/Debugging Fles
In-System Sources and Probes File
Logic Analyzer Interface File
SignalTap II Logic Analyzer File
University Program VWF

~ Other Files
AHDL Indude File
Block Symbol File
Chain Description File
Synopsys Design Constraints File
Text File

Cancel Help
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Entity B AT =EE o0 oM 08 4
/iy Cyclone III: EP3C16F484C6 1 Dentity mux2tol is
muxtol 2 Hport(s,d0,dl: in bit;
3 y: out bit);
4 end;
5
6 Harchitecture arc of mux2tol is
7 Hbegin
8 y<= d0 when s='0"' else dl;
9
10 end;
11
File =>Save As yalpn NIXINY o
Save s x
Savein: I quartus13_ex j & |‘=_°i€ v
* MName - Date modified Type
Cuick access db 27/02/2019 20012 File folder
Desktop
M
Libraries
This PC
Ne&wcrk

<

>
File: name: ImuxEto‘I whd j Save I
Save as type: I‘u"HDL Files (*.vhd *.vhdl) ;I Cancel |

r

[v Add file to cument project

entity Level Top - NNIAN NN 7W DUN KINY 0'1N90N DWD Yalzn 7w DY

Yalgn DX 79077 e

File Edit Vie Project Assignments Processing Tools ndo Help &
DE AP % @9 o i Hy s SFS[F)p 0 w2 ee s @
Project Navigator Bax | & mux2tol.vhd® B »*
Entiy I LT WIS
/iy Cyclone III: EP3C16F484C6 1 Hentity mux2tol is
mu2tol % 2 Hport(s,d0,dl: in bit;
3 y: out bit);
4 end:

[I'N AN W



:N'Y7IM'07 "N WTN yaly NN

' 3 VHDL File

* Memory Files
Hexadedmal (Intel-Format) File
Memaory Initialization File

* Verification/Debugging Files
In-System Sources and Probes File
Logic Analyzer Interface File

i File
University Program YWF
L

AHDL Incude File
Block Symbal File

NINIX X77 D720 170 7222 MWRY N¥'N7 WNXY

%} Simulation Waveform Editor - Dt/quartus13_sx/mux2te] - mux2tol - [Waveform1.wwf] - m} =
File Edit View Simulaton Help = @
5] & % 0t & NEME B NC )T 02 R | KR R A |
Master Time Bar: 4 » | Pointer: |22‘96 ns Interval: 22,96 ns | Start: | | End: | |
0ps 180.0 ns 320.0 ns 480.0 ns 640.0 ns 800.0 ns 960.0 ns
Name Value at f f i i \ \
Ops Jps

2us 7wn? Edit =>set End Time. N'X7In'on [T NX Y27

N'Miynwn 2Iman nt) 100ns 7wnY Edit => Grid Size NIMIWN 7w NINNN 7712 X Nva
(20 nrpwnn

N'x¥71'07 NINIX NO1N

%;- Simulation Waveform Editor - Dt/quartus13_ex/muwxtol - muwctel - [Waveformoanwf]*

File | Edit View Simulaton Help 57

[ X Do ol B AT N1
Insert * E Insert Node or Bus j h
Mast al: |14.13 ns
Value 2
Grouping y Ons 400.IU ns EUU.IU ns SUU.IU ns 1.0I

Reverse Group or Bus Bit Order

Radix r

[I'N AN W



&4 Insert Mode or Bus *
MName: | || I oK I
Type: INPUT - Cancel
Value type: | 9-Level -

Radix: Binary

Bus width: | 1 |

Start index: |D |

Display gray code count as binary count

List yn%

&) Mode Finder >

Named: |‘1 Filter: | Pins: all -

Look in: |= | | List I Cancel

Modes Found: Selected Modes:
Na\rae Type Na\rae Type
=
OK 72 7nNI >> ynY
&4 Mode Finder >

MNamed: |= Filter: |Pins: all -

Look in: |‘ List Cancel
Modes Found: Selected Modes:
Mame Type Na\rfwe Type
in_ oo Input
in_ D1 Input
in_ g Input -
My Output [ - ]
EY
<<

:NaN |I7nn DX 7

g; Simulation Waveform Editor - D/ quartus3_ex/muxte] - muxdtol - [Waveform.vwf]™ — O >

Search altera.com @

Fle Edit View Smulaton Help 5
G| @[3 0 Z T E I8 KE 08 00 R | wn m¥ A | B
Master Time Bar: 4 b | Pointer: |3.53 ns ‘Inberval: |3.53 ns |Smrt: | |Er1d: | |

Ops 200.0ns 400.0ns 600.0ns 800.0ns 1.0us 1.2us 1.4us 1.6us 1.8us 20us
Value at ' ' i ' | i 1 |

Mame

Ops 0 ps
in_ BO
n_ D1 BO
n_ s BO
L ¥ BX

AI'RN '97 SEL, D1 -7 200nsec , DO-7 100nsec T2 [IVYW XNAIT? , D72 010N o
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[n10nn 19N 2y Yn'71 DO NX N0

5 tol - [Wa wil* - O

Vie u " Help & Search alter
NEEEES S S'C I B LA 1L

Master Time Bar: « || » | painter: [156.05ns Interval: [166.05ns | Start: [0ps | End: [2.0us

Ops 200.0ns 400.0ns 600.0ns  B800.0ns 1.0us 1.2us 1.4us l6us 1.8us
\ \ \ \ \ 1 '

Value at i )
Mame Ops 3 ps
n Do BD
n_ b1 B0
: & Clock X
B 5 BO
au v BX Base waveform on time period

Period: |10p.0 ns v

Duty cycle (%): |50 5
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2 Search

Tl EL KO N E T E B NCEZ R ED AN A B

| Master Time Bar: L] » | Pointer: |?’D.66 ne Interval: | 70.66 ns |513rt: |U ps |End: E

Ops 200.0ns 400.0ns ©00.0ns B800.0ns 1.0us 1.2us 1.4us 1.6us 1.8
Name Value at ' ' ' ' ' ' ' | |
Ops 0ps
n_ Do BO
B D1 BO
Bl s BO
an oy % & Clock by
Base waveform on time period
S——
Cancel
[aionn TPoN *T* 7V nton 7 117 '1' 2¥n%? S NN |noa
&4 Simulation Waveform Editor - D/ quartus13_ex'muxte] - mux2tel - [Waveformamaf]™ — O '

Fle Edit View Smuaton Hep 5
Z O E BOCE 2 R i e A a8

Master Time Bar: 4 » | Pointer: |10.6 ns | Interval: |10.6 ns | Start: |SDD.E| ns | End: |1.45 us

Ops 200.0ns 400.0ns &00.0ns B800.0ns 1.0us 1.2us 1.4us 1.6us 1.8us 20us
Mame Value at | | | ' I i | ) )
0ps
0ps P
n_ Do BO
L | b1 BO
n 5 BO | |
o ¥ BX
270 W NIrwn K77 YN
€ X8 X2 [ A |l B
b | Pointer: (853,25 ns Interval: |883.25ns
wTN 17N 7371
&4 Simulation Waveform Editor - [mutol simawf (Read-Only)] — O pl

Fie Edt View Smuaton Help 5 [ search altera.com|l
|, % & N Z WD E BONCOE T R | WY el A |

Master Time Bar: 1 » | Pointer: ‘514.69 ns Interval: (514,69 ns |Smrt: | |End: |

Value at Ops 160.0ns 320.0ns 480.0ns &40.0ns 800.0ns 980.0ns 1.12us 1.28us 1.44us 1.6us 176us 192us
| v v \ i | v | :
Ops 0ps

oo

o,
L5

Mame

Do T I O A I
o p1 BO

5s B0 | |

@l v iy I I N IS NS 1 N A B O Y B
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T7ON 7V YN'71 2070 7Y NIFUNN T 0Oy n¥1) DX
patil
&4 Simulation Waveform Editor - [mux2to.simawf (Read-Only]] — O X

Fie Edit View Simulaton Help &
B 5 0 2 E M B B 2 e 8 ng 2 (2%
Master Time Bar: 4 » | Pointer: |112.4 ns | Interval: |112.4 ns | Start: ‘ | End: |

Ops 160.0ns 320.0ns 480.0ns 640.0ns B800.0ns 960.0ns 1.12us 1.28us 1.44us 1.6us 1.76 us 1.92us
i ' ' ' ' ' f ' ' ' f

Value at
Ops 0ps

o D1 BO

L | s B0 | |

= ¥ BX

n2A"XI 02'S NN

NINAN NIX720N 97 7segment ,0'¥NY7 ,0'7091 ,0'T7 112'NY7 02'90 NN

3.3V

BUTTONO

& e

BUTTON1

Q AN G3 Cyclone?’ﬂl’
BUTTONZ

Q AN F1

Table 4.2. Pin assignments for the pushbutton switches

Signal Name FPGA Pin No. Description
BUTTON [0] PIN_H2 Pushbutton[0]
BUTTON [1] PIN_G3 Pushbutton[1]
BUTTON [2] PIN_F1 Pushbutton[2]
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D2 E4

Cyclonef@m

E3 H7 J7

H5 J6

SW9 Sws SW7 SWeé SW5 SW4 SW3 SW2 Swi1 SWo

Logic 1"

d

|
Logic™ 0™

Figure 4.6. Connections between the toggle switches and Cyclone 111 FPGA

Table 4.1. Pin assignments for the slide switches
Signal Name FPGA Pin No. Description
SW[0] PIN_J6 Slide Switch[0]
SW[1] PIN_H5 Slide Switch[1]
SW[2] PIN_H6 Slide Switch[2]
SW[3] PIN_G4 Slide Switch[3]
SW[4] PIN_G5 Slide Switch[4]
SW5] PIN_J7 Slide Switch[5]
SWe] PIN_H7 Slide Switch[6]
SW[7] PIN_E3 Slide Switch[7]
SW[8] PIN_E4 Slide Switch[g]
SW[g] PIN_D2 Slide Switch[g]
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Figure 4.7. Connections between the LEDs and Cyclone 111 FPGA

Table 4.3. Pin assignments for the LEDs

Signal Name FPGA Pin No. Description
LEDGI0] PIN_J1 LED Green[0]
LEDG[1] PIN_J2 LED Green[1]
LEDGI[2] PIN_J3 LED Green[2)
LEDG[3] PIN_H1 LED Green[3]
| FDG[4] PIN_F2 L ED Green[4]
LEDGI5] PIN_E1 LED Green[5]
LEDG[6] PIN_C1 LED Green[6]
LEDGI[7] PIN_C2 LED Green[7]
LEDGI[8] PIN_B2 LED Green[8]
LEDG[9] PIN_B1 LED Green[9]
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HEXO0

HEX0_D0 HEXO0 DO
oD ) “HEX0_D1 ::1'
M < HEX0_D2
HEX0_D5 HEX0_D1[ : HEX0_D3 ::;
HEX0_D6 ) @
o Cyclone~ 1l
HEX0_D4
HEX0_D4 HEX0_D2 [+ “—Ex0 D5 G12
) “HEX0_D6 0
s HEX0_DP | ~ HEX0_DP
HEX0_D3 @ = | < = D13

13

Figure 4.8. Connections between the 7-segment displays and Cyclone 11l FPGA

Table 4.4, Pin assignments for the T-segment displays.

Signal Name FPGA Pin No. Description
HEXD D0 PIN_E11 Seven Segment Digit Gj0Y
HEXD_D{1] PIN_F11 Seven Segment Digil 01
HEXD_D{2] PIN_H12 Seven Segment Digil 02)
HEXD_D{3] PIN_H13 Seven Segment Digil 03
HEXD_D{4] PIN_G12 Seven Segmend Digil 04)
HEXD_D{5] PIN_F12 Seven Segment Digil 05
HEXD_D§E] PIN_F13 Seven Segment Digit GjE)
HEXD_DP PIN_D13 Seven Segment Decimal Point 0
HEX1_D{0 PIN_A13 Seven Segment Digit 1§
HEX1_D{1] PIN_B13 Seven Segment Digit 1[1]
HEX1_D{2] PIN_C13 Seven Segment Digil 12)
HEX1_D{3] PIN_A14 Seven Segment Digil 1]3)
HEX1_D{4] PIN_B14 Seven Segment Digil 14
HEX1_D{5] PIN_E14 Seven Segment Digil 1]5]
HEX1_D{8] PIN_A15 Seven Segment Digil 18]
HEX1_DP PIM_B15 Seven Segment Decimal Poirt 1
HEXZ D0 PIN_D16 Seven Segment Digit 2§0Y
HEXZ Dfi] PIN_A1E Seven Segment Digit 2{1]
HEXZ_D{2] PIN_B1E Seven Segment Digil 22)
HEXZ_D{3] PIN_E15 Seven Segment Digil 3
HEXZ_D{4] PIN_A17 Seven Segment Digil 204
HEXZ_D{5] PIN_B17 Seven Segment Digil 28]
HEXZ_D{8] PIN_F14 Seven Segment Digil 28]
HEX2_DP PIM_A1B Seven Segment Decimal Point 2
HEX3 D0 PIN_B18 Seven Segment Digit 30
HEX3 D{i] PIN_F15 Seven Segment Digit 31]
HEX3_D{2] PIN_A1D Seven Segment Digil 2]
HEX3_D{3] PIN_B1% Seven Segment Digil 33
HEX3_D{4] PIN_C19 Seven Segment Digil 34)
HEX3_D{5] PIN_DiD Seven Segment Digil 5]
HEX3_D{g] PIN_G15 Seven Segment Digil 8]
HEX3_DP PiH_G18 Seven Segment Decimal Point 3
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CLOCK_50

50MHz
0osC

¥

G21 (CLK4)

CLOCK_50_2

Y

B21 (CLK9)

GPIO 0 (J4)

GPIO0_CLKINO

F 3

(CLK12) AB12
(CLK13) AA12

A

GPIO0_CLKIN1

GPIO0_CLKOUTOD

(PLL1_CLKOUTn) AB3

GPIO0_CLKOUT1 |

(PLL1_CLKOUTp) AA3

(auﬂoneﬁ?ﬂl

GPIO 1 (J5)

GPIO1_CLKINO

(CLK14) AB11 |«
(CLK15) AA11

GPIO1_CLKIN1 | 4

F Y

GPIO1_CLKOUTO _

(PLL4_CLKOUTN) R16
(PLL4_CLKOUTp) T6

GPIO1_CLKOUT1 |

Figure 4.10. Block diagram of the clock distribution.

Table 4.5. Pin assignments for the clock inputs.
Signal Name FPGA Pin No. Description
CLOCK_50 PIN_G21 50 MHz clock input
CLOCK_50_2 PIN_B12 50 MHz clock input
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Pin Planner — 011'o ny1ap?7 0N e

Help 7

< Gale - ¢l

@ W e i

mux2tol.vhd B @

®= -
=
e |
141
(1]
[Tl

=E oM om0 S 8 E

LEDR[0] Nana xximi SW[0] jpoon S-7 , KEY[0],KEY[1] n'a¥n? DO,D1 : Ni0Y1d7 N1 e

; Named: * ~ |&» | Editt X o |
o Node Name Direction Location I/o Bank VREF Group Fitter Location /O Standard Reserved Current Strengtt Slews Rate Differential Pair
in_ do Input PIN_H2 1 B1_N1 FIN_K8 2.5 V (default) 8mA (default)
in_d1 Input PIN_G3 1 B1_NO PIN_F7 2.5 V (default) 8mA (default)
o s Input PIN_J6 1 B1_NO PIN_V4 2.5 V (default) 8maA (default)
oty Output PIN_J1 1 B1_N1 FIN_K7 2.5 V (default) 8maA (default) 2 (default)

<<new node>>

N'X7'0n1j yx11 e

USB-Blaster NX Mj7an NI7 T '/pNn? 1Y W', USB -1 NNnNan) e

P 80 e

N1 N1l e

| -.'} Compilation Repart - mux2tol

Thu Feb 28 22:10:23 2019
232 06/12/2013 SP 1 5] Web Edition

Start 7y yn'2a1 USB — Blaster n2"x7 7n11 e
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3@ Programmer - Dt/quartus13_ex/muxtol - mux2to] - [output_files/mux2tol.cdf]

File Edit View Processing Tools ‘Window Help S

j. Hardware Set..u:l...l |USB-EIaster [usB-0] | I Mode: |JTAG b Progress: [
[] Enable real-time ISP to allow background programming (for MAX II and MAX V devices)
m File Device Checksum Usercode Program/
il Start Configure
Jib stop output_files/mux2tol.sof  EP2C35F672 002F8557 002F8557
&y Auto Detect
. Delete

[ add Fie...

12 Change File...

Al Save File
(4 Add Device...
i up

i Dowin

EP2C35F572

F

N2'IXN DX 0'VdN 7Y 7iITa) e
POBIBEOR10 my oy 55 o2 B Vo " w W
il S5 s
S o o o o i i i i

TN

1963 LA e e

N
UNIVERSITY
PROGRAM
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