DE2 o0'LY)>— Quartus NIY¥nx1A 1?7 PN

8V DC Power USB Ethemet
Supply Blaster US8 USB Mic Une Line Video 101100M  RS-232
Connector Port Device Host In In Oul In VGA Out Pon Port

28.63MHz Oscllator
Audio CODEC
Power ON/OFF Switch
USB Host/Slave
Controfer
Altera USB Blaster
Controller Chipset
Altera EPCS16
Configuration Device
Switch between JTAG
/Normal Mode(RUN)
and AS Mode(PROG)

16x2 LCD Module

PS/2 Pont

VGA 10-bt DAC

Expansion Header 2 (JP2)
Expansion Header 1 (JP1)
Ethemet 10/100M Controller
TV Decoder(NTSC/PAL)

Allera 80 nm Cyclone 1|
FPGA with 35K LEs

SO Card Socket
4Mbyte Flash Memory
7-SEG Dssplay
DA Transcelver
SMA Ext Cik

18 Red 18 SPODT EMbyte 512 Koyte S0MHz 4 Push-butions 8 Green LEDs
LEDs Switches SDRAM SRAM  Oscillator

QUARTUS 13.0

in Performance & Productivity
for CPLD, FPGA, SoC FPGA, and HardCopy® ASIC designs

Design Software v13.0

QUARTUS II

AITERAW

MEASRABLE ADVANTAGE™

[I'N 2N W



N1DINA QY nATIAY2 NRIYN NIT

0'"10"N 1AV NS0 J'\IXP:'\'? W 1

NTI9 N'P'N y'min project 707 .2

nYv

File => Close Project 0"'j7 U7'IND NA0 o

File => New Project Wizard wTn 0'N® NN'NS e

& New Project Wizard

Introduction

The Mew Project Wizard helps you create a new project and preliminary project settings, induding the following:

Project name and directory

NMame of the top-evel design entity
Project files and libraries

Target device family and device
EDA tool settings

You can change the settings for an existing project and spedify additional project-wide settings with the Settings command (Assignments menu). You can use
the various pages of the Settings dialog box to add functionality to the project.

teeee

[] Don't shaw me this introduction again

< Back

Finish Cancel Help

x

nnian A"dM'NN DYI VP'NS DY , NS0 1N e

&4 New Project Wizard

Directory, Name, Top-Level Entity [page 1 of 5]

What is the working directory for this project?

|D:fuuam_|s 13_ex ‘

What is the name of this project?

|mux2t01| ‘

What is the name of the top-evel design entity for this project? This name is case sensitive and must exactly match the entity name in the design file.

|mux2b:|l ‘

Use Existing Project Settings...

< Back Finish Cancel Help

X
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€4 New Project Wizard X

Add Files [page 2 of 5]

Select the design files you want to indude in the project. Click Add Al to add al design files in the project drectory to the project.
Note: you can always add design files to the project later.

File name: I Add

FleNsme Type Library Design Entry/Synthess Tool " HOL Version " AddAl
Remove
Up
Dowm

Propertes

Specify the path names of any non-default ibraries. User Libraries...

< Back

DE2- 0'0D7 D'RNNN QDY N] e

&4 Mew Project Wizard x

Family & Device Settings [page 3 of 5]

Select the family and device you want to target for compilation.
You can install additional device support with the Install Devices command on the Tools menu.

Device famil Show in'Available devices' list
Famil - Package: Any -
Devices: |Al W Pin count: Any -
Target device Speed grade: | Any v
() Auto device selected by the Fitter Name filter: |
(®) Specific device selected in 'Available devices' list Show advanced devices HardCopy compatible only &)
Other: nfa
Availzble devices:
Mame Core Voltage LEs User I/0s Memory Bits Embedded multiplier 9-bit elements PLL G~
EP2C35F484C8 1.2v 33216 322 483840 70 4 16
33216 322 433640 70 4 16
672 33216 475 433640 70 4 16
EP2C35F672C8 1.2V 33216 475 433840 70 4 15
EP2C35F67218 1.2V 33216 475 433640 70 4 16
FDIC 36 14R40A 1 W 3R 377 4r3Ran n a w v
€ >
Companion device =)
HardCopy: -

Limit DSP & RAM to HardCopy device resources

Cancel Help
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% [b_/\/\, Cyclone device on DE2

.N1222 7'won R¥INA LED -1 7112 7091, 001V NynY 7ayn oy 0x¥N7n yT'nn niotd
File=>New wTN YaIl7 NND e

VHDL2I0ON2 o

& New X
New Quartus II Project ~
¥ Design Files
AHDL File
Block Diagram fSchematic File
EDIF File

Qeys System File
State Machine File
SystemVerilog HDL File
Td Script File

Verilog HDL File
VHDL File
~ MEMBTYTTE

Hexadedmal (Intel-Format) File
Memory Initialization File

' Verification/Debugging Files
In-System Sources and Probes File
Logic Analyzer Interface File
SignalTap II Logic Analyzer File
University Program VWF

~ Other Files
AHDL Indude File
Block Symbol File
Chain Description File
Synopsys Design Constraints File
Text File

Cancel Help

EDITOR-Nn 0N TIZN MK QM) @

A Ed @ 4 539 o imuxl Y E¢%e O e 0D

Project Navigator 18 x Vhdl1.vhd*

@
Entity AT O TOm 0 8 R

% Cydone II: EP2C35F672C6

1
¥ mux2tol S 2
3
4
5 Hentity muxZtol is
5 = port(DO,D1l:in =td 1
7 SEL: in std logics
8 F :out std logic
9 end max2tol;
10
11 [Harchitecturs arc mux of mux2tol is
12 [Hbkegin
. 13 L F <= DB when SEL='0' else D1;
/&% Hierarchy @Files ¢ Design Units QJL‘ 14 end arc mux;
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File =>Save As yalpn NIXINY e

Save s x
Savein: I quartus13_ex j & |‘=_°i€ v
* MName - Date modified Type
) db 27/02/2019 20:12 File folder
Quick access
Desktop
M
Libraries
This PC
Ne&work
< >
File name: Imutho‘I whd j Save I
Saveastype:  |VHDL Files {"vhd ".vhd) | Cancel |

[+ Add file to cument project

r

entity Level Top - NNI2aN N'SI'NN 7Y DWN RINY LR'NSN DWD Yalzn Y oW

Window Help S

- .:x.d;‘

) mux2to1.vhd -.'}

1@aaT

Yalign X 7907 e

A LA SO i @ P

Compilation Re

nehNocm 08 4 R

| = EEE

library ieee;

own s L B

use ieee.std logic llé4.all;

Elentity mux2tol is
=l port(D0,Dl:in std logic;

NN7IM'07 TN WTN YAl NND e

WHOL File

* Memaory Files
Hexadedmal (Intel-Format) File
Memory Initialization File

% Verification/Debugging Files
In-System Sources and Probes File
Loqic Analyzer Interface File

i File
University Program VWF
~

AHDL Indude File
Blodk Symbaol File
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g; Simulation Waveform Editor - Di/quartus13_sx/muxte] - muxZtol - [Waveform1.wwf] — ] b

Fle Edit WView Simdaton Help 5 @

PERE- TR O G O R I G el -l

Master Time Bar: 4 » | Pointer: |22‘96 ns Interval: | 22,96 ns |513rt: | |End: | |

0ps 180.0 ns 320.0 ns 480.0 ns 640.0 ns 800.0 ns 960.0 ns
Value at f f i i ' \
Ops Jps
4

Name

2us 7wun? Edit =>set End Time. N'X710'0N AT DX VA7)

N'MIynun 71man nt) 100ns 7wnY Edit => Grid Size NIMIWN 7w NINNN 7712 X Nva
(@A™ nhwnn

N'X7IM'07 NINIXK NO1N e

%3 Simulation Waveform Editor - Dt/quartus13_ex/mux2tol - muctel - [Waveformonwf]™

File  Edit Vien Simulaton Help 5

W XK Delets Del E YT YR | e Y 2 |8
Insert 3
Mast ! Insert Node or Bus... ! I.ah 14.13 ne
Value 3
Grouping > ns 400'.0 ns EUU.IU ns BUU.IU ns 1.IZJI

Reverse Group or Bus Bit Order

Radix »
&4 Insert Mode or Bus *
MName: || I oK I
Type: INPUT A Cancel
Value type: |9-Level -
Mode Finder...
Radix: Binary -
Bus width: | 1 |
Start index: |D |
Display gray code count as binary count
List yn?
&4 Node Finder >

Mamed: |'1 Filter: |Pins: all A

Look in: |= | | List I Cancel

Modes Found: Selected Nodes:
Mame Type Mame Type
>
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OK 72 "nXI >> yn?

&4 Mode Finder X
Named: |‘ Filter: |Pins: all hd
Lookin: |= List Cancel
MNodes Found: Selected Modes:
Mame Type Na\rae Type
in_po Tnput
in_pi1 Input
n_ g Input -
ot
=Y Qutput
= tp [ o ]
<
<<

INAN 17NN DX

g; Simulation Waveform Editor - Di/quartus13_ex/muxte] - mux2tol - [Waveformomd]* - O *

Fle Edit View Simulaton Hep 5 @

b &3 O h ZNEE BB )2 )R wR R A | By
Master Time Bar: 4 | Pointer: |3.53 ns ‘Irlterval: |3.53 ns |Smrt: | |Er1d: | |

Ops 200.0ns 400.0ns ©00.0ns 800.0ns 1.0us 1.2us Laus l.ous 1l.8us 20us
' ' \ ' ' ' 1 ' '

Value at

Mame

Ops 0ps
L
in
[
n_ D1 BO
n 5 BO
u ¥ BX

AI'RN 97 SEL, D1 -7 200nsec , DO-7 100nsec AT [IVY XNAIT? , D722 010N o

[nionn Ton 2y yn'?1 DO NX |no

x/mux2tol - mux2tol - [Waveform.vwf]* — m}

File Edit Vie Simulation  Help & Search alter
NERE SN b Ve [ D AT

Master Time Bar: 4 | v | Painter: [166.05ns Interval: | 166.05 ns | start: [aps | End: [2.0us

Ops 200.0ns 400.0ns 600.0ns 2300.0ns 1.0us 1.2us 1.4us l.6us 1.8us
\ \ \ \ | | '

oo

B

Value at | \
Mame Ops 3 ps
L
n_ oo BO
in D1 BO
[
: & Clock X
B 5 BO
out ¥ BX Base waveform on time period

Period: |10p.0 ns v

Duty cyde (%): |50 S

Cancel
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D1-7 71

2 Search

IHINERE RN R S B A R L

| Master Time Bar: L] » | Pointer: |?’D.66 ne Interval: | 70.66 ns |513rt: |U ps |End: E

Ops 200.0ns 400.0ns ©00.0ns B800.0ns 1.0us 1.2us 1.4us 1.6us 1.8
Name Value at ' ' ' ' ' ' ' | |
Ops 0ps
n_ Do BO
B D1 BO
Bl s BO
an oy % & Clock by
Base waveform on time period
S——
Cancel
[n1Ionn TPoN T 7y n'on |At7 117 '1' a¥n%? S NX noa
&4 Simulation Waveform Editor - D/ quartus13_ex'muxte] - mux2tel - [Waveformamaf]™ — O '

Fle Edit View Smuaton Hep 5
Z O E BOCE 2 R i e A a8

Master Time Bar: 4 » | Pointer: |10.6 ns | Interval: |10.6 ns | Start: |SDD.E| ns | End: |1.45 us

Ops 200.0ns 400.0ns &00.0ns B800.0ns 1.0us 1.2us 1.4us 1.6us 1.8us 20us
Mame Value at | | | ' I i | ) )
0ps
0ps P
n_ Do BO
L | b1 BO
n 5 BO | |
o ¥ BX
2070 7w NIrnwn K77 yna
€ X8 X2 [ A |l B
b | Pointer: (853,25 ns Interval: |883.25ns
wTN 17N 73571
&4 Simulation Waveform Editor - [mutol simawf (Read-Only)] — O pl

Fie Edt View Smuaton Help 5 [ search altera.com|l
|, % & N Z WD E BONCOE T R | WY el A |

Master Time Bar: 1 » | Pointer: ‘514.69 ns Interval: (514,69 ns |Smrt: | |End: |

Ops 160.0ns 320.0ns 480.0ns 640.0ns 800.0ns 960.0ns 1.12us 1.28us  1.44us 1.6us 1.76us 1.92us
| v v \ i | v | :

oo

o,
L5

Value at ' ' b
Name Ops 0ps
n_ Do BO
o p1 BO
ns BO | |
M Y BO
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%; Simulation Waveform Editor - [muxtel.simawwf (Read-Only)]

Fie Edit View Simulaton Help &

R 5 0 A Z ) B EE 2 )6 b8 ag 2

gatall

- [m] *

Search altera.com 6

» | Pointer: [112.4ns

| start: |

Value at

Ops 160.0ns 320.0ns 480.0ns 640.0ns B800.0ns 960.0ns
i ' ' ' ' '

1.12us  1.28us  1.44us
f '

Ops 0ps
L

naA"XxXI 0'2'S N'Na

NINAN NIX720N '97 7segment ,0'¥NY ,0'7091 ,0'T7 1I2'N7 D' N NN @

SWI0] PIN_N25 Toggle Switch[0)]
SW[1) PIN_M28 Toggle Switch(1)
SW[2) PIN_P25 Toggle Switch(2)
SW[3) PIN_AE14 Toggle Switch(3)
SW4) PIN_AF14 Toggle Switch(4)
SW(5) PIN_AD13 Toggle Switch(5)
SWI8) PIN_AC13 Toggle Switch(6]
SWI7) PIN_C13 Toggle Switch(7)
SWIE] PIN_B13 Toggle Switch(8]
SWg) PIN_A13 Toggle Switch(9)
SW[10] PIN_N1 Togale Switch{10]
SW[11) PIN_P1 Togale Switch{11]
SW[12) PIN_P2 Toggle Switch{12]
SW[13) PIN_T7 Toggle Switch{13]
SW[14) PIN_U3 Toggle Switch[14]
SW[15) PIN_U4 Toggle Switch(15]
SW[16) PIN_V1 Toggle Switch(16]
SW[17) PIN_V2 Toggle Switch(17]
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KEY][0] PIN_G26 Pushbutton[(]
KEY[1] PIN_N23 Pushbutton[1]
KEY[2] PIN_P23 Pushbutton[2]
KEY[3] PIN_W26 Pushbutton[3]

LEDR(0] PIM_AEZ3 LED Red[0]
LEDR[1] FIN_AFZ3 LED Red[1]
LEDR[Z] PIM_ABZ1 LED Red[2]
LEDR[3] PIN_ALZZ LED Red[3]
LEDR[4] PIN_ADZZ LED Red[4]
LEDR[S] PIN_ADZ3 LED Red[5]
LEDR[E] PIN_ADE LED Red[6]
LEDR[T] PIN_ACH LED Red[7]
LEDR[3] PIM_AATA LED Red[a]
LEDR[3] PIN_¥13 LED Red[3]
LEDR{10] PIN_AAT3 LED Red[10]
LEDR{11] PIN_ACT4 LED Red[11]
LEDR{12] PIN_AD1S LED Red[12]
LED®R]13] PIM_AE15 LED Red[13]
LEDR{14] PIM_AF13 LED Red[14]
LEDR{15] PIN_AE13 LED Red[15]
LED#]16] PIM_AE1Z LED Red[16]
LEDR{1T] PIN_AD1Z LED Red[17]
LEDG[0] PIM_AEZZ LED Green[0]
LEDG[1] PIM_AF22 LED Gresn[1]
LEDG[Z] PIN_ W13 LED Green[2]
LEDG[3] PIN_V18 LED Gresn[3]
LED{G[4] PIN_LIME LED Grean[d]
LEDG[S] PIN_UMT LED Gresn[5]
LED{GIE] PIM_AAZD LED Gresn[t]
LEDG[T] PIN_Y18 LED Gresn[7]
LEDG[E) PIN_¥12 LED Gresn[]
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7segment 8 N1aY

HEXD[O] PIM_AF10 Seven Segment Digit O[0)
HEX0[1] PIN_AB12 Seven Segment Digit O[1)
HEXD[2] PIN_AC12 Seven Segment Digit 0[2)
HEX0[3] PIN_AD11 Seven Segment Digit O[3)
HEX0[4] PIN_AE11 Seven Segment Digit 0[4)
HEX0[5] PIM_\14 Seven Segment Digit O[5)
HEX0[E] PIM_\13 Seven Segment Digit O[]
HEX1[0] PIM_\20 Seven Segment Digit 1[0)
HEX1[1] PIM_V21 Seven Segment Digit 1[1]
HEX1[2] PIN_W21 Seven Segment Digit 1[2)
HEX1[3] PIM_Y¥22 Seven Segment Digit 1[3)
HEX1[4] PIMN_AAZ24 Seven Segment Digit 1[4]
HEX1[5] PIN_AAZ3 Seven Segment Digit 1[5)
HEX1[B] PIN_AB24 Seven Segment Digit 1[6)
HEX2[0] PIN_AB23 Seven Segment Digit 2[0)
HEX2[1] PIN_\W22 Seven Segment Digit 2[1)
HEX2[2] PIN_AC25 Seven Segment Digit 2[2)
HEX2[3] PIN_AC2E Seven Segment Digit 2[3)
HEX2[4] PIN_AB26 Seven Segment Digit 2[4]
HEX2[5] PIN_AB25 Seven Segment Digit 2[5)
HEX2[6] PIN_Y24 Seven Segment Digit 2[E)
HEX3[0] PIM_¥23 Seven Segment Digit 3[0)
HEX3[1] PIN_AA2S Seven Segment Digit 3[1)
HEX3[2] PIN_AAZE Seven Segment Digit 3[2)
HEX3[3] PIM_Y26 Seven Segment Digit 3[3)
HEX3[4] PIM_¥25 Seven Segment Digit 3[4]
HEX3[5] PIN_L122 Seven Segment Digit 3[5)
HEX3[6] PIN_W24 Seven Segment Digit 3[5)
HEX4[0] PIN_LID Seven Segment Digit 4[0)
HEX4[1] PIN_LI1 Seven Segment Digit 4[1)
HEX4[2] PIN_LI2 Seven Segment Digit 4[2)
HEX4[3] FIM_T4 Seven Segment Digit 4[3)
HEX4[4] PIN_RT Seven Segment Digit 4[4)
HEX4[5] PIN_RE Seven Segment Digit 4[5)
HEX4[B] FIM_T3 Saven Segment Digit 4[5)
HEXS[0] FIM_T2 Seven Segment Digit 5[0)
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HEX5[1] PIN_PB Seven Segment Digit 5[1)
HEX5[2] PIN_PY Seven Segment Digit 5[2)
HEX5[3] PIN_TS Seven Sagment Digit 5[3]
HEX5[4] PIN_RS Seven Segment Digit 5[4)
HEX5[5] PIN_R4 Seven Segment Digit 5[5)
HEX5[6] PIN_R3 Seven Segment Digit 5[8)
HEXE[0] PIM_R2 Seven Segment Digit 6[0)
HEX@[1] PIN_P4 Seven Segment Digit 6[1)
HEXEB[2] PIN_P3 Seven Segment Digit 6[2)
HEXB[3] PIM_B2 Seven Segment Digit 6[3)
HEXG[4] PIM_BM3 Seven Segment Digit 6[4)
HEXE[5] PIN_MS Seven Sagment Digit 6[5]
HEXB[E] PIN_B4 Seven Segment Digit 6[8)
HEX7[0] PIM_L3 Seven Segment Digit T[0)
HEXT[1] PIM_L2 Seven Segment Digit 7[1)]
HEX7[2] PlM_LD Seven Segment Digit T[2)
HEX7[3] PIM_LE Seven Sagment Digit T[3]
HEX7[4] PIM_LT Seven Segment Digit T[4)
HEXT[5] PIN_P9 Seven Segment Digit T[5)
HEXT[E] PIN_NE Seven Segment Digit T[8)
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Pin Planner — 0'1'o ny1ap? 0N e

Ve U rw G

Pin Planner m

Help &
llF -y
mzto1ohd
e EE 00NDOH | S

e

261
268

LEDR[O] nana xxIni SW[0] 7o9n S-7 , KEY[0],KEY[1] nxaxn'? DO,D1 : Ni0'1d71n1) e

| ||

= h x

Narned: * v |« Edit |

|Filter. Pins: all

Mode Name Direction Location I/O Bank VREF Group Fitter Location /O Star
& Do Input PIN_G26 & B6 N2 FIN_AB23 25V
L b1 Input PIN_pNZ3 & B6 N1 PIN_AC28 25V
- F Output PIN_ N25 7 B7_N2 PIN_G12 25V
B SEL Input PIN_AE23 5 B5 N1 PIN_M23 25V

n'xY7'oN17 yx11 e

USB-Blaster NX Man Ni7 T '/pNn? 7Y W', USB -1 NNn Nan) e

7 OO e

N1XN1) e

| Q Compilation Report - mux2to1

Thu Feb 28 22:10:23 2019
232 UE;"lF.'fEUlE SP 151 Web Edition
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Start 7y yn'211 USB — Blaster n2aMx7 1011 e

w Programmer - Di/quartus13_ex/mux2tol - mux2tel - [output_files/mux2to.cdf]

File Edit View Processing Tools ‘Window Help =

j. Hardware Set..u:l...l |USB-EIaster [usB-0] | I Mode: |JTAG b Progress: [
[] Enable real-time ISP to allow background programming (for MAX II and MAX V devices)

File Device Checksum Usercode Program/
Configure

o stap output_filesfmux2tol.sof  EP2C35FG72 002F8557 002F8557

b start

&y Auto Detect

., Delete

[ add Fie...

Y& change File...

‘A save File
(2% Add Device...
fiup

ﬂ,‘ﬁl Down

EP2C35F572

N2M¥N NN 0'VDN 7Y PITA) e

| 51:2 4

FERIRRRRURGRTRRITY -§

2 ) bl d Ll b e b o R

eteieeivieeiol S5 L o

SEL DO,D1
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